Re: [PATCH v2 1/6] soc: qcom: rpmpd: Add a powerdomain driver to model corners

From: Ulf Hansson
Date: Thu May 31 2018 - 07:09:36 EST


On 31 May 2018 at 06:20, Rajendra Nayak <rnayak@xxxxxxxxxxxxxx> wrote:
>
>
> On 05/30/2018 06:14 PM, Ulf Hansson wrote:
>> [...]
>>
>>>>> +
>>>>> +static DEFINE_MUTEX(rpmpd_lock);
>>>>> +
>>>>> +/* msm8996 RPM powerdomains */
>>>>> +DEFINE_RPMPD_CORN_SMPA(msm8996, vddcx, vddcx_ao, 1);
>>>>> +DEFINE_RPMPD_CORN_SMPA(msm8996, vddmx, vddmx_ao, 2);
>>>>> +DEFINE_RPMPD_CORN_LDOA(msm8996, vddsscx, 26);
>>>>> +
>>>>> +DEFINE_RPMPD_VFC_SMPA(msm8996, vddcx_vfc, 1);
>>>>> +DEFINE_RPMPD_VFC_LDOA(msm8996, vddsscx_vfc, 26);
>>>>> +
>>>>> +static struct rpmpd *msm8996_rpmpds[] = {
>>>>> + [0] = &msm8996_vddcx,
>>>>> + [1] = &msm8996_vddcx_ao,
>>>>> + [2] = &msm8996_vddcx_vfc,
>>>>> + [3] = &msm8996_vddmx,
>>>>> + [4] = &msm8996_vddmx_ao,
>>>>> + [5] = &msm8996_vddsscx,
>>>>> + [6] = &msm8996_vddsscx_vfc,
>>>>> +};
>>>>
>>>> It's not my call, but honestly the above all macros makes the code
>>>> less readable.
>>>
>>> This is all static data per SoC. The macros will keep the new additions
>>> needed for every new SoC to a minimal. Currently this supports only
>>> msm8996.
>>
>> Right, that's fine then.
>>
>>>
>>>>
>>>> Anyway, I think you should convert to allocate these structs
>>>> dynamically from the heap (kzalloc/kcalloc), instead of statically as
>>>> above.
>>
>> However, I assume this is still doable!?
>
> Perhaps it is, but is there any specific advantage of constructing these structures
> dynamically vs statically, given they are static data?

Well, I was just thinking that the genpd struct has grown quite big.

> Most other powerdomain/clock/regulator drivers I see do it statically, and thats
> what I followed.

Right, so forget it and keep it as is.

Kind regards
Uffe