Re: [PATCH v2 01/21] usb: phy: use match_string() helper
From: Yisheng Xie
Date: Tue Jun 05 2018 - 05:29:37 EST
On 2018/6/1 2:59, Andy Shevchenko wrote:
> On Thu, May 31, 2018 at 9:56 PM, Sergei Shtylyov
> <sergei.shtylyov@xxxxxxxxxxxxxxxxxx> wrote:
>> On 05/31/2018 09:47 PM, Andy Shevchenko wrote:
>>>>> - int err, i;
>>>>> + err = match_string(usbphy_modes, ARRAY_SIZE(usbphy_modes), phy_type);
>>>>> + if (err < 0)
>>>> This is one of the few cases when 'err' is not the best name for such a
>>>> variable. I'd prefer to see something like 'match' or even 'rc' or 'ret'... :-)
>>> Then leaving i would make it?
>> Yes. :-)
> So, I leave it to Greg to decide either it's okay in this version, or
> needs update with i left untouched.
IIRC, you seems want to keep the err unchanged, right?
Please let me know if another version is need.
>>> I'm okay with either which just not renames err, b/c it's used with
>>> something else in this function.
>> Looking at it again, 'err' seems equally bad for the result of
>> of_property_read_string()... unless the check there is changed to just *if* (err) --
>> this function never returns positive values, 0 means success, others mean error.
> While you seems right, this is matter of another change which you are
> welcome to propose.