Re: [PATCH 0/4] Small cleanup for memoryhotplug

From: Jonathan Cameron
Date: Thu Jun 07 2018 - 06:43:06 EST


On Fri, 1 Jun 2018 14:53:17 +0200
<osalvador@xxxxxxxxxxxxxxxxxx> wrote:

> From: Oscar Salvador <osalvador@xxxxxxx>
>
>
> Hi,
>
> I wanted to give it a try and do a small cleanup in the memhotplug's code.
> A lot more could be done, but I wanted to start somewhere.
> I tried to unify/remove duplicated code.
>
> The following is what this patchset does:
>
> 1) add_memory_resource() has code to allocate a node in case it was offline.
> Since try_online_node has some code for that as well, I just made add_memory_resource() to
> use that so we can remove duplicated code..
> This is better explained in patch 1/4.
>
> 2) register_mem_sect_under_node() will be called only from link_mem_sections()
>
> 3) Get rid of link_mem_sections() in favour of walk_memory_range() with a callback to
> register_mem_sect_under_node()
>
> 4) Drop unnecessary checks from register_mem_sect_under_node()
>
>
> I have done some tests and I could not see anything broken because of
> this patchset.
Works fine with the patch set for arm64 I'm intermittently working on.
Or at least I don't need to make any additional changes on top of what I currently
have!

Tested-by: Jonathan Cameron <Jonathan.Cameron@xxxxxxxxxx>

Thanks,

Jonathan
>
> Oscar Salvador (4):
> mm/memory_hotplug: Make add_memory_resource use __try_online_node
> mm/memory_hotplug: Call register_mem_sect_under_node
> mm/memory_hotplug: Get rid of link_mem_sections
> mm/memory_hotplug: Drop unnecessary checks from
> register_mem_sect_under_node
>
> drivers/base/memory.c | 2 -
> drivers/base/node.c | 52 +++++---------------------
> include/linux/node.h | 21 +++++------
> mm/memory_hotplug.c | 101 ++++++++++++++++++++++++++------------------------
> 4 files changed, 71 insertions(+), 105 deletions(-)
>