Re: [GIT PULL] Kbuild updates for 4.18 (2nd round)
From: Masahiro Yamada
Date: Wed Jun 13 2018 - 14:16:34 EST
2018-06-14 2:49 GMT+09:00 Linus Torvalds <torvalds@xxxxxxxxxxxxxxxxxxxx>:
> On Wed, Jun 13, 2018 at 10:29 AM Masahiro Yamada
> <yamada.masahiro@xxxxxxxxxxxxx> wrote:
>> I cannot come up with a name better than CC_STACKPROTECTOR_STRONG.
> How about just calling it STACKPROTETOR_STRONG and leaving it at that?
> Make the "CC_HAVE_xyz" model for compiler feature tests, but when
> actually picking an actual option, it's not really about the compiler
> any more, except in the sense that it depends on it.
I just respected the original naming,
but CC_ is not sensible any more.
> I guess we could leave the CC_STACKPROTECTOR option as-is, just
> because it apparently has a lot of small uses in actual code too, but
> there is absolutely nothing that uses CONFIG_CC_STACKPROTECTOR_STRONG
> outside of the actual compiler option choice (and config files)
I agree to rename CC_STACKPROTECTOR_STRONG to STACKPROTECTOR_STRONG.
But, I'd like to rename CC_STACKPROTECTOR to STACKPROTECTOR as well.
I guess 30 lines or so in the C code usage.
Could you run sed directly in your tree?