Re: [PATCH v3 1/5] md: Avoid namespace collision with bitmap API

From: Andy Shevchenko
Date: Mon Jun 18 2018 - 09:57:49 EST


On Mon, 2018-06-18 at 09:44 -0400, Mike Snitzer wrote:
> On Mon, Jun 18 2018 at 9:09am -0400,
> Andy Shevchenko <andriy.shevchenko@xxxxxxxxxxxxxxx> wrote:
>
> > bitmap API (include/linux/bitmap.h) has 'bitmap' prefix for its
> > methods.
> >
> > On the other hand MD bitmap API is special case.
> > Adding 'md' prefix to it to avoid name space collision.
> >
> > No functional changes intended.
> >
> > Signed-off-by: Andy Shevchenko <andriy.shevchenko@xxxxxxxxxxxxxxx>
> > ---
> > drivers/md/dm-raid.c | 6 +-
> > drivers/md/md-bitmap.c | 301 +++++++++----
> > -----
> > drivers/md/md-bitmap.h | 46 +--
> > drivers/md/md-cluster.c | 16 +-
> > drivers/md/md.c | 44 +--
> > .../md/persistent-data/dm-space-map-common.c | 12 +-
> > drivers/md/raid1.c | 20 +-
> > drivers/md/raid10.c | 26 +-
> > drivers/md/raid5-cache.c | 2 +-
> > drivers/md/raid5.c | 24 +-
> > 10 files changed, 244 insertions(+), 253 deletions(-)
>
> Seems my previous mail just missed your v3 cutoff but...
>
> <snip>
>
> All of these drivers/md/persistent-data/dm-space-map-common.c renames
> are wrong.

So, let me understand this clear, the naming problem appears in one file
only. The rest is fine. Correct?

> DM is the only consumer (it is confusing because all DM and
> MD code lives in drivers/md/ despite only sharing a bit of MD code).
>
> Anyway, please rename bitmap methods in this file to have a
> "dm_bitmap"
> prefix instead. Thanks.

Ah, okay, will do this in v4 later this week.

Thanks for review!

--
Andy Shevchenko <andriy.shevchenko@xxxxxxxxxxxxxxx>
Intel Finland Oy