Re: [PATCH 2/3] x86/kvm: Implement MSR_HWCR support

From: Borislav Petkov
Date: Fri Jun 22 2018 - 15:09:21 EST


On Fri, Jun 22, 2018 at 08:52:38PM +0200, Radim KrÄmÃÅ wrote:
> msr_info->host_initiated is always going to return true, so it would be
> better to put it outside of __set_mci_status.
>
> Maybe we could just write the whole logic inline, otherwise I'd call it
> something like mci_status_is_writeable.
>
> > static int set_msr_mce(struct kvm_vcpu *vcpu, struct msr_data *msr_info)
> > {
> > u64 mcg_cap = vcpu->arch.mcg_cap;
> > @@ -2176,9 +2200,13 @@ static int set_msr_mce(struct kvm_vcpu *vcpu, struct msr_data *msr_info)
> > if ((offset & 0x3) == 0 &&
> > data != 0 && (data | (1 << 10)) != ~(u64)0)
> > return -1;
> > - if (!msr_info->host_initiated &&
> > - (offset & 0x3) == 1 && data != 0)
> > - return -1;
> > +
> > + /* MCi_STATUS */
> > + if ((offset & 0x3) == 1) {
> > + if (!__set_mci_status(vcpu, msr_info))
> > + return -1;
> > + }
>
> if (!msr_info->host_initiated &&
> (offset & 0x3) == 1 && data != 0) {
> struct msr_data tmp = {.index = MSR_K7_HWCR};
>
> if (!guest_cpuid_is_amd(vcpu) ||
> !kvm_x86_ops->get_msr(vcpu, &tmp) ||
> !(tmp.data & BIT_ULL(18)))
> return -1;

Don't you feel it is cleaner if all the MCi_STATUS checking is done in
a separate function? The indentation level and the bunch of checks in
set_msr_mce() make it hard to read while having a separate function
separates it and makes it easier to follow.

I mean, you're the maintainer but if I may give a suggestion, moving the
whole logic into a separate function would be more readable.

And then do:

if (!msr_info->host_initiated) {
if (check_mci_status(...))
return -1;
}

Something like that...

--
Regards/Gruss,
Boris.

Good mailing practices for 400: avoid top-posting and trim the reply.