Re: [PATCH V10] powercap/drivers/idle_inject: Add an idle injection framework
From: Rafael J. Wysocki
Date: Wed Jul 04 2018 - 06:50:52 EST
On Tuesday, June 26, 2018 1:01:05 PM CEST Viresh Kumar wrote:
> On 26-06-18, 12:53, Daniel Lezcano wrote:
> > Initially, the cpu_cooling device for ARM was changed by adding a new
> > policy inserting idle cycles. The intel_powerclamp driver does a
> > similar action.
> > Instead of implementing idle injections privately in the cpu_cooling
> > device, move the idle injection code in a dedicated framework and give
> > the opportunity to other frameworks to make use of it.
> > The framework relies on the smpboot kthreads which handles via its
> > main loop the common code for hotplugging and [un]parking.
> > This code was previously tested with the cpu cooling device and went
> > through several iterations. It results now in split code and API
> > exported in the header file. It was tested with the cpu cooling device
> > with success.
> > Signed-off-by: Daniel Lezcano <daniel.lezcano@xxxxxxxxxx>
> > Cc: Viresh Kumar <viresh.kumar@xxxxxxxxxx>
> > Cc: Eduardo Valentin <edubezval@xxxxxxxxx>
> > Cc: Javi Merino <javi.merino@xxxxxxxxxx>
> > Cc: Leo Yan <leo.yan@xxxxxxxxxx>
> > Cc: Kevin Wangtao <kevin.wangtao@xxxxxxxxxx>
> > Cc: Vincent Guittot <vincent.guittot@xxxxxxxxxx>
> > Cc: Rui Zhang <rui.zhang@xxxxxxxxx>
> > Cc: Daniel Thompson <daniel.thompson@xxxxxxxxxx>
> > Cc: Peter Zijlstra <peterz@xxxxxxxxxxxxx>
> > Cc: Andrea Parri <andrea.parri@xxxxxxxxxxxxxxxxxxxx>
> > ---
> > V10:
> > - Remove set_freezable (Rafael J. Wysocki)
> > - Reduce the prefixed names 'injection' by 'inject" (Rafael J. Wysocki)
> > - Rename 'idle_injection_wakeup_fn()' to 'idle_inject_timer_fn()' (Rafael J. Wysocki)
> > - Shorten label 'out_rollback_per_cpu' to 'out_rollback' (Rafael J. Wysocki)
> Reviewed-by: Viresh Kumar <viresh.kumar@xxxxxxxxxx>
I've applied the patch, but I've rewrittent all of the comments in it.
Daniel, please check the result in linux-next and let me know if you see any