Re: [PATCH 09/12] nubus: use for_each_if

From: Finn Thain
Date: Mon Jul 09 2018 - 06:16:20 EST


On Mon, 9 Jul 2018, Daniel Vetter wrote:

> Avoids the inverted check compared to the open-coded version.
>
> Signed-off-by: Daniel Vetter <daniel.vetter@xxxxxxxxx>
> Cc: Finn Thain <fthain@xxxxxxxxxxxxxxxxxxx>
> Cc: linux-m68k@xxxxxxxxxxxxxxxxxxxx

Acked-by: Finn Thain <fthain@xxxxxxxxxxxxxxxxxxx>

> ---
> include/linux/nubus.h | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/include/linux/nubus.h b/include/linux/nubus.h
> index eba50b057f6f..17fd07578ef7 100644
> --- a/include/linux/nubus.h
> +++ b/include/linux/nubus.h
> @@ -127,7 +127,7 @@ struct nubus_rsrc *nubus_next_rsrc_or_null(struct nubus_rsrc *from);
> for (f = nubus_first_rsrc_or_null(); f; f = nubus_next_rsrc_or_null(f))
>
> #define for_each_board_func_rsrc(b, f) \
> - for_each_func_rsrc(f) if (f->board != b) {} else
> + for_each_func_rsrc(f) for_each_if (f->board == b)
>
> /* These are somewhat more NuBus-specific. They all return 0 for
> success and -1 for failure, as you'd expect. */
>