Re: [PATCH 09/12] nubus: use for_each_if

From: Geert Uytterhoeven
Date: Tue Jul 17 2018 - 11:26:36 EST


Hi Daniel,

On Mon, Jul 9, 2018 at 10:44 AM Daniel Vetter <daniel.vetter@xxxxxxxx> wrote:
> Avoids the inverted check compared to the open-coded version.
>
> Signed-off-by: Daniel Vetter <daniel.vetter@xxxxxxxxx>
> Cc: Finn Thain <fthain@xxxxxxxxxxxxxxxxxxx>
> Cc: linux-m68k@xxxxxxxxxxxxxxxxxxxx

Thanks for your patch!

> --- a/include/linux/nubus.h
> +++ b/include/linux/nubus.h
> @@ -127,7 +127,7 @@ struct nubus_rsrc *nubus_next_rsrc_or_null(struct nubus_rsrc *from);
> for (f = nubus_first_rsrc_or_null(); f; f = nubus_next_rsrc_or_null(f))
>
> #define for_each_board_func_rsrc(b, f) \
> - for_each_func_rsrc(f) if (f->board != b) {} else
> + for_each_func_rsrc(f) for_each_if (f->board == b)

drivers/net/ethernet/8390/mac8390.c: In function âmac8390_device_probeâ:
drivers/net/ethernet/8390/mac8390.c:402: error: implicit declaration
of function âfor_each_ifâ
drivers/net/ethernet/8390/mac8390.c:402: error: expected â;â before â{â token

Apparently this depends on patch [01/12], which wasn't CCed to
linux-m68k@xxxxxxxxxxxxxxxxxxxx?

Please don't split CCs if all patches in the a series are not independent.
Thanks!

Gr{oetje,eeting}s,

Geert

--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@xxxxxxxxxxxxxx

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
-- Linus Torvalds