Re: [RFC v7 PATCH 2/4] mm: mmap: zap pages with read mmap_sem in munmap

From: Yang Shi
Date: Fri Aug 10 2018 - 14:26:42 EST




On 8/10/18 10:57 AM, Matthew Wilcox wrote:
On Fri, Aug 10, 2018 at 07:36:01AM +0800, Yang Shi wrote:
+/*
+ * Zap pages with read mmap_sem held
+ *
+ * uf is the list for userfaultfd
+ */
+static int do_munmap_zap_rlock(struct mm_struct *mm, unsigned long start,
+ size_t len, struct list_head *uf)
I don't like the name here. We aren't zapping rlocks, we're zapping
pages. Not sure what to call it though ...

It may look ambiguous, it means "zap with rlock", but I don't think anyone would expect we are zapping locks.

Thanks,
Yang