Re: [BUG] Loopback devices with 4k logical block size are not automatically scanned for GPT partitions

From: Andrew Jeddeloh
Date: Fri Aug 10 2018 - 15:33:23 EST

I tried with qemu virtio-blk-pci (couldn't find a qemu option for
logical or physical block size for virtio-scsi-pci) and it found the
partition when booting. I see

virtio_blk virtio1: [vdb] 262144 4096-byte logical blocks (1.07 GB/1.00 GiB)

quickly followed by

vdb: vdb1

on dmesg on bootup. I haven't tried hotplugging it yet. I don't know
if that would matter.

- Andrew Jeddeloh

On Thu, Aug 9, 2018 at 1:10 AM, Ming Lei <tom.leiming@xxxxxxxxx> wrote:
> On Thu, Aug 9, 2018 at 7:30 AM, Andrew Jeddeloh
> <andrew.jeddeloh@xxxxxxxxxx> wrote:
>> I think I found a bug with partition scanning/loopback devices with 4k
>> logical sectors. It affects 4.14.x and 4.17.x kernels (and presumably
>> others). I've also filed the bug on the kernel bugzilla:
>> Copied from the bugzilla report:
>> Loop devices with the logical sector size set to 4096 do not
>> autodetect partitions when attached. It may be the case for devices
>> with 4k logical sectors in general, but I do not have hardware to test
>> that. I have not tested with non-GPT disks.
> You may setup 4k sector-size with scsi_debug or qemu virtio-scsi,
> then try to reproduce on these devices.
> Cc block list.
> Thanks,
> Ming Lei