Re: [PATCH] mtd: rawnand: atmel: use struct_size() in devm_kzalloc()

From: Miquel Raynal
Date: Tue Sep 04 2018 - 17:58:34 EST


Hi Gustavo,

"Gustavo A. R. Silva" <gustavo@xxxxxxxxxxxxxx> wrote on Thu, 23 Aug
2018 20:09:38 -0500:

> One of the more common cases of allocation size calculations is finding
> the size of a structure that has a zero-sized array at the end, along
> with memory for some number of elements for that array. For example:
>
> struct foo {
> int stuff;
> void *entry[];
> };
>
> instance = devm_kzalloc(dev, sizeof(struct foo) + sizeof(void *) * count, GFP_KERNEL);
>
> Instead of leaving these open-coded and prone to type mistakes, we can
> now use the new struct_size() helper:
>
> instance = devm_kzalloc(dev, struct_size(instance, entry, count), GFP_KERNEL);
>
> This issue was detected with the help of Coccinelle.
>
> Signed-off-by: Gustavo A. R. Silva <gustavo@xxxxxxxxxxxxxx>
> ---

Applied to nand/next.

Thanks,
MiquÃl