[PATCH 0/6] mount-api: fixes and cleanups

From: Miklos Szeredi
Date: Thu Sep 20 2018 - 11:12:24 EST


These fix issues with handling subtype (fuse specific thing) and rename
some constants on the new API to make me happy. I realize the last patch
could be viewed as bikeshedding, but I do think suggesting falsehood in a
constant name can lead to painful real life bugs, so now is the time to
think about these issues.

Miklos Szeredi (6):
selinux: fold superblock_doinit() into only caller
vfs_submount: use SB_SUBMOUNT instead of MS_SUBMOUNT
mount: fix regression in setting "subtype" from legacy API
fsconfig: parse "subtype" param for old internal API
fsmount: do not use legacy MS_ flags
fsconfig: rename FSCONFIG_CMD_CREATE to FSCONFIG_CMD_OBTAIN

fs/fs_context.c | 44 +++++++++------------------------------
fs/fsopen.c | 6 +++---
fs/namespace.c | 51 +++++++++++++++++++++++++++++++---------------
include/uapi/linux/fs.h | 2 +-
include/uapi/linux/mount.h | 9 ++++++++
samples/vfs/test-fsmount.c | 2 +-
security/selinux/hooks.c | 37 ++++++++-------------------------
7 files changed, 68 insertions(+), 83 deletions(-)

--
2.14.3