Re: [PATCH resend] x86, asm: Use CC_SET()/CC_OUT() for __cmpxchg_double

From: Uros Bizjak
Date: Mon Oct 01 2018 - 07:04:03 EST


On Mon, Oct 1, 2018 at 12:28 PM Borislav Petkov <bp@xxxxxxxxx> wrote:
>
> On Fri, Sep 28, 2018 at 10:33:05AM +0200, Uros Bizjak wrote:
> > Remove open-coded uses of set instructions to use CC_SET()/CC_OUT()
> > for __cmpxchg_double.
> >
> > Signed-off-by: Uros Bizjak <ubizjak@xxxxxxxxx>
> > ---
> > arch/x86/include/asm/cmpxchg.h | 10 ++++++----
> > 1 file changed, 6 insertions(+), 4 deletions(-)
> >
> > diff --git a/arch/x86/include/asm/cmpxchg.h b/arch/x86/include/asm/cmpxchg.h
> > index a55d79b233d3..bfb85e5844ab 100644
> > --- a/arch/x86/include/asm/cmpxchg.h
> > +++ b/arch/x86/include/asm/cmpxchg.h
> > @@ -242,10 +242,12 @@ extern void __add_wrong_size(void)
> > BUILD_BUG_ON(sizeof(*(p2)) != sizeof(long)); \
> > VM_BUG_ON((unsigned long)(p1) % (2 * sizeof(long))); \
> > VM_BUG_ON((unsigned long)((p1) + 1) != (unsigned long)(p2)); \
> > - asm volatile(pfx "cmpxchg%c4b %2; sete %0" \
> > - : "=a" (__ret), "+d" (__old2), \
> > - "+m" (*(p1)), "+m" (*(p2)) \
> > - : "i" (2 * sizeof(long)), "a" (__old1), \
> > + asm volatile(pfx "cmpxchg%c5b %1" \
> > + CC_SET(e) \
> > + : CC_OUT(e) (__ret), \
> > + "+m" (*(p1)), "+m" (*(p2)), \
> > + "+a" (__old1), "+d" (__old2) \
> > + : "i" (2 * sizeof(long)), \
>
> To quote checkpatch:

Looks like gmail forward mangled whitespace. The original, archived at
Patchwork [1] passes checkpatch without problems.

[1] https://mail.google.com/mail/u/0/#inbox/LXphbRLrghxkrJptDWnbbJcrVBkBsRQgcnbtRLjbGSq

Uros.