Re: [PATCH v3 1/2] arm/arm64: KVM: rename function kvm_arch_dev_ioctl_check_extension()
From: James Morse
Date: Fri Oct 12 2018 - 11:45:41 EST
Hi Dongjiu Geng,
On 11/10/2018 20:07, Dongjiu Geng wrote:
> Rename kvm_arch_dev_ioctl_check_extension() to
> kvm_arch_vm_ioctl_check_extension(), because it does
> not have any relationship with device.
> Renaming this function can make code readable.
Lots of things in the kernel are misnamed, its not normally worth fixing them.
But it confused me, so:
Acked-by: James Morse <james.morse@xxxxxxx>