Re: [Patch v3 08/13] x86/speculation: Rename SSBD update functions
From: Thomas Gleixner
Date: Thu Oct 18 2018 - 09:37:32 EST
On Wed, 17 Oct 2018, Tim Chen wrote:
> This is a clean up patch that doesn't change any
This is not a cleanup. It's a preparatory patch and again you want to
explain first the context and then what you are doing.
> functionality. We rename intel_set_ssb_state to
> spec_ctrl_update_msr, speculative_store_bypass_update to
> speculation_ctrl_update and speculative_store_bypass_update_current to
There is no point in listing all what the patch is doing. We all can see
that from the patch itself. And again 'We'? We are doing nothing. Please
write your changelogs in imperative mode, like Documentation/process
> This prepares us to update of other bits in the SPEC_CTRL MSR
The speculative store bypass related functions are controlling the SSBD
bit in SPEC_CTRL_MSR depending on a TIF flag.
For more fine grained control of STIBP this control needs to be extended,
so the SSB naming convention does not apply anymore.
Rename the functions to a more generic name.
Looks good otherwise.