RE: [PATCH] tpm: tpm_try_transmit() refactor error flow.

From: Winkler, Tomas
Date: Tue Oct 23 2018 - 10:16:21 EST


>
>
> On Sat, 20 Oct 2018, Winkler, Tomas wrote:
>
> >>
> >> On Thu, 18 Oct 2018, Winkler, Tomas wrote:
> >>>> -----Original Message-----
> >>>> From: Jarkko Sakkinen [mailto:jarkko.sakkinen@xxxxxxxxxxxxxxx]
> >>>> Sent: Thursday, October 18, 2018 03:15
> >>>> To: Winkler, Tomas <tomas.winkler@xxxxxxxxx>
> >>>> Cc: Jarkko Sakkinen <jarkko.sakkinen@xxxxxxxxxxxxxxx>; Jason
> >>>> Gunthorpe <jgg@xxxxxxxx>; Nayna Jain <nayna@xxxxxxxxxxxxxxxxxx>;
> >>>> Usyskin, Alexander <alexander.usyskin@xxxxxxxxx>; Struk, Tadeusz
> >>>> <tadeusz.struk@xxxxxxxxx>; linux-integrity@xxxxxxxxxxxxxxx;
> >>>> linux-security- module@xxxxxxxxxxxxxxx;
> >>>> linux-kernel@xxxxxxxxxxxxxxx; stable@xxxxxxxxxxxxxxx
> >>>> Subject: Re: [PATCH] tpm: tpm_try_transmit() refactor error flow.
> >>>>
bb> >>>> On Tue, 16 Oct 2018, Tomas Winkler wrote:
> >>>>> First, rename out_no_locality to out_locality for bailing out on
> >>>>> both
> >>>>> tpm_cmd_ready() and tpm_request_locality() failure.
> >>>>
> >>>> This is unnecessary change and technically it is not a rename: the
> >>>> commit message text and the code change do not match. Rename is
> >>>> just a rename (i.e. change a variable name foo to bar).
> >>>
> >>> I'm renaming the label because it doesn't match the code flow
> >>> anymore, I can change the commit message, but you please review the
> code.
> >>> Tomas
> >>
> >> The flow change is unnecessary and does not really have anything to
> >> do with the bug fix.
> >
> > What I see in the original code is that when
> > tpm_cmd_ready() fails it's jumps to 'out' label and trying to do
> > tpm_go_idle() but instead it should just undoing the locality, so both
> > cmd_read and go idle had a wrong jump. I see both should be fixed.
> >
> > Earlier version was better than this and would have been fine
> >> when taking account the remark from Jason.
>
> So you are doing tpm_cmd_ready() change in order to prevent unnecessary
> call to tpm_go_idle() that was previously i.e. before when that function
> failed in jumped to out and called tpm_go_idle()?

>
> This should be probably split into two commits if I understood right. You did
> not have this updated mentioned in a changelog (there was no changelog).

I'm not sure why to do it in two steps, this addresses the same issue.

> Have you checked that if these were separate commits they would have the
> same fixes line? Why not use the label name 'out' as the same label handles
> bot 'locality' and 'no_locality'?

To the out label we jump after we are done with locality and cmd read() before we jump to locality 'locality'.
We will need to add another variable to check If cmd_ready() was called or not in order to get rid of the extran label,
it's not internally tracked so far.
I'm not sure what is better, I prefer this short fix, as the transmit() has to be rewritten anyway at some point, the recursion what is there is not helthy.

Thanks
Tomas