Re: [Outreachy kernel] [PATCH] drm: Rename crtc_idr as object_idr to KMS cleanups
From: Shayenne Moura
Date: Wed Oct 31 2018 - 17:19:43 EST
On 10/31, Julia Lawall wrote:
> On Wed, 31 Oct 2018, Shayenne da Luz Moura wrote:
> > Rename 'drm_mode_config.crtc_idr' as 'drm_mode_config.object_idr',
> > as proposed in the task description in TODO list for KMS cleanups.
> Is object_idr a field that already exists? If so, "Rename" is not the
> best choice of words. It should be something like "use the object_idr
> field instead of the crtc_idr field" and then explain why. "task
> description in TODO list for KMS cleanups" isn't very helpful to
> understand why the change should be made.
Thank you for your review!
This patch is to solve this TODO task:
drm_mode_config.crtc_idr is misnamed, since it contains all KMS object.
Should be renamed to drm_mode_config.object_idr.
Do you think I need to use this description in my commit message?