Re: [PATCH 2/2] mm/sparse: add common helper to mark all memblocks present

From: Logan Gunthorpe
Date: Wed Nov 07 2018 - 15:19:28 EST




On 2018-11-07 1:12 p.m., Andrew Morton wrote:
>> +void __init memblocks_present(void)
>> +{
>> + struct memblock_region *reg;
>> +
>> + for_each_memblock(memory, reg) {
>> + memory_present(memblock_get_region_node(reg),
>> + memblock_region_memory_base_pfn(reg),
>> + memblock_region_memory_end_pfn(reg));
>> + }
>> +}
>> +
>
> I don't like the name much. To me, memblocks_present means "are
> memblocks present" whereas this actually means "memblocks are present".
> But whatever. A little covering comment which describes what this
> does and why it does it would be nice.

The same argument can be made about the existing memory_present()
function and I think it's worth keeping the naming consistent. I'll add
a comment and resend shortly.

> Acked-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx>
>
> I can grab both patches and shall sneak them into 4.20-rcX, but feel
> free to merge them into some git tree if you'd prefer. If I see them
> turn up in linux-next I shall drop my copy.

Sounds good, thanks.

Logan