[PATCH -next v2 00/12] pstore: various clean-ups

From: Kees Cook
Date: Thu Nov 29 2018 - 18:08:57 EST


This is a collection of clean-ups from Joel Fernandes, Peng Wang, and
myself. I wanted to put the entire series up for review since they've
changed a bit from their earlier incarnations. I intend to push them to
next shortly...

Thanks!

-Kees


Joel Fernandes (Google) (3):
pstore: Map PSTORE_TYPE_* to strings
pstore/ram: Simplify ramoops_get_next_prz() arguments
pstore/ram: Do not treat empty buffers as valid

Kees Cook (8):
pstore/ram: Correctly calculate usable PRZ bytes
pstore: Do not use crash buffer for decompression
pstore: Remove needless lock during console writes
pstore/ram: Standardize module name in ramoops
pstore/ram: Report backend assignments with finer granularity
pstore/ram: Add kern-doc for struct persistent_ram_zone
pstore: Improve and update some comments and status output
pstore: Replace open-coded << with BIT()

Peng Wang (1):
pstore: Avoid duplicate call of persistent_ram_zap()

drivers/acpi/apei/erst.c | 2 +-
fs/pstore/inode.c | 51 ++-------------
fs/pstore/platform.c | 129 ++++++++++++++++++++-----------------
fs/pstore/ram.c | 75 +++++++++------------
fs/pstore/ram_core.c | 45 ++++++++++---
include/linux/pstore.h | 32 ++++++---
include/linux/pstore_ram.h | 50 +++++++++++++-
7 files changed, 212 insertions(+), 172 deletions(-)

--
2.17.1