Re: [PATCH 03/12] __wr_after_init: generic functionality

From: Matthew Wilcox
Date: Fri Dec 21 2018 - 13:41:26 EST


On Fri, Dec 21, 2018 at 08:14:14PM +0200, Igor Stoppa wrote:
> +static inline int memtst(void *p, int c, __kernel_size_t len)

I don't understand why you're verifying that writes actually happen
in production code. Sure, write lib/test_wrmem.c or something, but
verifying every single rare write seems like a mistake to me.

> +#ifndef CONFIG_PRMEM

So is this PRMEM or wr_mem? It's not obvious that CONFIG_PRMEM controls
wrmem.

> +#define wr_assign(var, val) ((var) = (val))

The hamming distance between 'var' and 'val' is too small. The convention
in the line immediately below (p and v) is much more readable.

> +#define wr_rcu_assign_pointer(p, v) rcu_assign_pointer(p, v)
> +#define wr_assign(var, val) ({ \
> + typeof(var) tmp = (typeof(var))val; \
> + \
> + wr_memcpy(&var, &tmp, sizeof(var)); \
> + var; \
> +})

Doesn't wr_memcpy return 'var' anyway?

> +/**
> + * wr_memcpy() - copyes size bytes from q to p

typo

> + * @p: beginning of the memory to write to
> + * @q: beginning of the memory to read from
> + * @size: amount of bytes to copy
> + *
> + * Returns pointer to the destination

> + * The architecture code must provide:
> + * void __wr_enable(wr_state_t *state)
> + * void *__wr_addr(void *addr)
> + * void *__wr_memcpy(void *p, const void *q, __kernel_size_t size)
> + * void __wr_disable(wr_state_t *state)

This section shouldn't be in the user documentation of wr_memcpy().

> + */
> +void *wr_memcpy(void *p, const void *q, __kernel_size_t size)
> +{
> + wr_state_t wr_state;
> + void *wr_poking_addr = __wr_addr(p);
> +
> + if (WARN_ONCE(!wr_ready, "No writable mapping available") ||

Surely not. If somebody's called wr_memcpy() before wr_ready is set,
that means we can just call memcpy().