Re: [PATCH] wireless: marvell: add checks for the return value of sysfs_create_group

From: Kalle Valo
Date: Tue Jan 08 2019 - 11:46:22 EST


Kangjie Lu <kjlu@xxxxxxx> writes:

> sysfs_create_group() could fail, so let's check its return values and
> issue error messages if it fails.
>
> Signed-off-by: Kangjie Lu <kjlu@xxxxxxx>
> ---
> drivers/net/wireless/marvell/libertas/mesh.c | 4 ++++

The correct prefix is "libertas: ".

https://wireless.wiki.kernel.org/en/developers/documentation/submittingpatches#commit_title_is_wrong

> --- a/drivers/net/wireless/marvell/libertas/mesh.c
> +++ b/drivers/net/wireless/marvell/libertas/mesh.c
> @@ -797,7 +797,11 @@ static void lbs_persist_config_init(struct net_device *dev)
> {
> int ret;
> ret = sysfs_create_group(&(dev->dev.kobj), &boot_opts_group);
> + if (ret)
> + pr_err("failed to create boot_opts_group.\n");

Please add an empty line here for readability and resend the patch as
v2.

> ret = sysfs_create_group(&(dev->dev.kobj), &mesh_ie_group);
> + if (ret)
> + pr_err("failed to create mesh_ie_group.\n");
> }
>
> static void lbs_persist_config_remove(struct net_device *dev)

--
Kalle Valo