Re: [PATCH v5 2/9] cpufreq: Auto-register the driver as a thermal cooling device if asked

From: Rafael J. Wysocki
Date: Tue Jan 29 2019 - 17:22:25 EST


On Tue, Jan 29, 2019 at 9:20 PM Amit Kucheria <amit.kucheria@xxxxxxxxxx> wrote:
>
> On Tue, Jan 29, 2019 at 2:43 PM Rafael J. Wysocki <rafael@xxxxxxxxxx> wrote:
> >
> > On Tue, Jan 29, 2019 at 6:46 AM Amit Kucheria <amit.kucheria@xxxxxxxxxx> wrote:
> > >
> > > On Tue, Jan 29, 2019 at 11:06 AM Viresh Kumar <viresh.kumar@xxxxxxxxxx> wrote:
> > > >
> > > > On 29-01-19, 10:25, Amit Kucheria wrote:
> > > > > All cpufreq drivers do similar things to register as a cooling device.
> > > > > Provide a cpufreq driver flag so drivers can just ask the cpufreq core
> > > > > to register the cooling device on their behalf. This allows us to get
> > > > > rid of duplicated code in the drivers.
> > > > >
> > > > > In order to allow this, we add a struct thermal_cooling_device pointer
> > > > > to struct cpufreq_policy so that drivers don't need to store it in a
> > > > > private data structure.
> > > > >
> > > > > Suggested-by: Stephen Boyd <swboyd@xxxxxxxxxxxx>
> > > > > Suggested-by: Viresh Kumar <viresh.kumar@xxxxxxxxxx>
> > > > > Signed-off-by: Amit Kucheria <amit.kucheria@xxxxxxxxxx>
> > > > > Reviewed-by: Matthias Kaehlcke <mka@xxxxxxxxxxxx>
> > > > > Tested-by: Matthias Kaehlcke <mka@xxxxxxxxxxxx>
> > > > > Acked-by: Viresh Kumar <viresh.kumar@xxxxxxxxxx>
> > > > > ---
> > > > > drivers/cpufreq/cpufreq.c | 13 +++++++++++++
> > > > > include/linux/cpufreq.h | 9 +++++++++
> > > > > 2 files changed, 22 insertions(+)
> > > > >
> > > > > diff --git a/drivers/cpufreq/cpufreq.c b/drivers/cpufreq/cpufreq.c
> > > > > index e35a886e00bc..0f9b50d3ee91 100644
> > > > > --- a/drivers/cpufreq/cpufreq.c
> > > > > +++ b/drivers/cpufreq/cpufreq.c
> > > > > @@ -19,6 +19,7 @@
> > > > >
> > > > > #include <linux/cpu.h>
> > > > > #include <linux/cpufreq.h>
> > > > > +#include <linux/cpu_cooling.h>
> > > > > #include <linux/delay.h>
> > > > > #include <linux/device.h>
> > > > > #include <linux/init.h>
> > > > > @@ -1318,6 +1319,11 @@ static int cpufreq_online(unsigned int cpu)
> > > > > if (cpufreq_driver->ready)
> > > > > cpufreq_driver->ready(policy);
> > > > >
> > > > > +#if IS_ENABLED(CONFIG_CPU_THERMAL)
> > > > > + if (cpufreq_driver->flags & CPUFREQ_IS_COOLING_DEV)
> > > > > + policy->cdev = of_cpufreq_cooling_register(policy);
> > > > > +#endif
> > > >
> > > > I am not sure if Rafael wanted it this way but maybe something like this:
> > > >
> > > > if (IS_ENABLED(CONFIG_CPU_THERMAL) &&
> > > > cpufreq_driver->flags & CPUFREQ_IS_COOLING_DEV))
> > > > policy->cdev = of_cpufreq_cooling_register(policy);
> > > >
> > > > We never wanted ifdef hackery to be in there :)
> > >
> > > OK, that makes more sense. Should I just send out a fixup patch or the
> > > entire series?
> >
> > Just a fixup patch, please.
>
> Please find attached a fixup patch suitable to add to the top of the
> series and use git rebase --autosquash on.

This isn't Patchwork-friendly, so can you send the complete patch
instead, please?