Re: [PATCH 06/35] ARM: davinci: wrap interrupt definitions with a macro for SPARSE_IRQ

From: Bartosz Golaszewski
Date: Tue Feb 05 2019 - 11:17:20 EST


pon., 4 lut 2019 o 23:32 David Lechner <david@xxxxxxxxxxxxxx> napisaÅ(a):
>
> On 1/31/19 7:38 AM, Bartosz Golaszewski wrote:
> > From: Bartosz Golaszewski <bgolaszewski@xxxxxxxxxxxx>
> >
> > This is done in preparation for selecting CONFIG_SPARSE_IRQ. The
> > interrupt numbers will then start at the predefined NR_IRQS offset.
> >
> > For now wrap all interrupt numbers with a macro and define
> > DAVINCI_INTC_START to 0. Logically nothing changes for now.
> >
> > Signed-off-by: Bartosz Golaszewski <bgolaszewski@xxxxxxxxxxxx>
> > ---
>
> Reviewed-by: David Lechner <david@xxxxxxxxxxxxxx>
>
> > diff --git a/arch/arm/mach-davinci/include/mach/irqs.h b/arch/arm/mach-davinci/include/mach/irqs.h
> > index 03c446635301..14fa668d4e8d 100644
> > --- a/arch/arm/mach-davinci/include/mach/irqs.h
> > +++ b/arch/arm/mach-davinci/include/mach/irqs.h
> > @@ -30,371 +30,374 @@
> > /* Base address */
> > #define DAVINCI_ARM_INTC_BASE 0x01C48000
> >
> > +#define DAVINCI_INTC_START 0
> > +#define DAVINCI_INTC_IRQ(_irqnum) (DAVINCI_INTC_START + (_irqnum))
>
> Almost not worth mentioning, but DAVINCI_INTC_START is only
> ever used once, so it could be omitted.

I'd like to leave it here - it's more readable that way.

Bart