Re: [PATCH net-next] mlxsw: spectrum_router: Use struct_size() in kzalloc()

From: Jiri Pirko
Date: Fri Feb 08 2019 - 02:15:30 EST


Fri, Feb 08, 2019 at 04:42:41AM CET, gustavo@xxxxxxxxxxxxxx wrote:
>One of the more common cases of allocation size calculations is finding
>the size of a structure that has a zero-sized array at the end, along
>with memory for some number of elements for that array. For example:
>
>struct foo {
> int stuff;
> struct boo entry[];
>};
>
>size = sizeof(struct foo) + count * sizeof(struct boo);
>instance = kzalloc(size, GFP_KERNEL)
>
>Instead of leaving these open-coded and prone to type mistakes, we can
>now use the new struct_size() helper:
>
>instance = kzalloc(struct_size(instance, entry, count), GFP_KERNEL)
>
>Notice that, in this case, variable alloc_size is not necessary, hence
>it is removed.
>
>This code was detected with the help of Coccinelle.
>
>Signed-off-by: Gustavo A. R. Silva <gustavo@xxxxxxxxxxxxxx>

Acked-by: Jiri Pirko <jiri@xxxxxxxxxxxx>