Re: [PATCH] dm-switch: use struct_size() in kzalloc()

From: Gustavo A. R. Silva
Date: Thu Feb 21 2019 - 10:27:14 EST


Hi all,

Friendly ping:

Who can take this?

Thanks
--
Gustavo

On 1/8/19 10:02 AM, Gustavo A. R. Silva wrote:
> One of the more common cases of allocation size calculations is finding the
> size of a structure that has a zero-sized array at the end, along with memory
> for some number of elements for that array. For example:
>
> struct foo {
> int stuff;
> void *entry[];
> };
>
> instance = kzalloc(sizeof(struct foo) + sizeof(void *) * count, GFP_KERNEL);
>
> Instead of leaving these open-coded and prone to type mistakes, we can now
> use the new struct_size() helper:
>
> instance = kzalloc(struct_size(instance, entry, count), GFP_KERNEL);
>
> This code was detected with the help of Coccinelle.
>
> Signed-off-by: Gustavo A. R. Silva <gustavo@xxxxxxxxxxxxxx>
> ---
> drivers/md/dm-switch.c | 3 +--
> 1 file changed, 1 insertion(+), 2 deletions(-)
>
> diff --git a/drivers/md/dm-switch.c b/drivers/md/dm-switch.c
> index fae35caf3672..8a0f057b8122 100644
> --- a/drivers/md/dm-switch.c
> +++ b/drivers/md/dm-switch.c
> @@ -61,8 +61,7 @@ static struct switch_ctx *alloc_switch_ctx(struct dm_target *ti, unsigned nr_pat
> {
> struct switch_ctx *sctx;
>
> - sctx = kzalloc(sizeof(struct switch_ctx) + nr_paths * sizeof(struct switch_path),
> - GFP_KERNEL);
> + sctx = kzalloc(struct_size(sctx, path_list, nr_paths), GFP_KERNEL);
> if (!sctx)
> return NULL;
>
>