Re: [PATCH v2 10/10] iio: ak8975: improve code readability

From: Jonathan Cameron
Date: Sun Mar 03 2019 - 10:30:42 EST


On Thu, 21 Feb 2019 18:02:55 +0100
"H. Nikolaus Schaller" <hns@xxxxxxxxxxxxx> wrote:

> - use temporary variable in get_mount_matrix()
> - remove , after { }
>
> Signed-off-by: H. Nikolaus Schaller <hns@xxxxxxxxxxxxx>
Applied.

Thanks,

Jonathan

> ---
> drivers/iio/magnetometer/ak8975.c | 8 +++++---
> 1 file changed, 5 insertions(+), 3 deletions(-)
>
> diff --git a/drivers/iio/magnetometer/ak8975.c b/drivers/iio/magnetometer/ak8975.c
> index db7214ac514c..43d08c089792 100644
> --- a/drivers/iio/magnetometer/ak8975.c
> +++ b/drivers/iio/magnetometer/ak8975.c
> @@ -746,12 +746,14 @@ static const struct iio_mount_matrix *
> ak8975_get_mount_matrix(const struct iio_dev *indio_dev,
> const struct iio_chan_spec *chan)
> {
> - return &((struct ak8975_data *)iio_priv(indio_dev))->orientation;
> + struct ak8975_data *data = iio_priv(indio_dev);
> +
> + return &data->orientation;
> }
>
> static const struct iio_chan_spec_ext_info ak8975_ext_info[] = {
> IIO_MOUNT_MATRIX(IIO_SHARED_BY_DIR, ak8975_get_mount_matrix),
> - { },
> + { }
> };
>
> #define AK8975_CHANNEL(axis, index) \
> @@ -792,7 +794,7 @@ static const struct acpi_device_id ak_acpi_match[] = {
> {"AK09911", AK09911},
> {"AKM9911", AK09911},
> {"AK09912", AK09912},
> - { },
> + { }
> };
> MODULE_DEVICE_TABLE(acpi, ak_acpi_match);
> #endif