Re: [PATCH 3/3] rhashtable: rename rht_for_each*continue as *from.

From: Miguel Ojeda
Date: Sun Mar 17 2019 - 03:50:28 EST

On Thu, Mar 14, 2019 at 6:10 AM NeilBrown <neilb@xxxxxxxx> wrote:
> The pattern set by list.h is that for_each..continue()
> iterators start at the next entry after the given one,
> while for_each..from() iterators start at the given
> entry.
> The rht_for_each*continue() iterators are documented as though the
> start at the 'next' entry, but actually start at the given entry,
> and they are used expecting that behaviour.
> So fix the documentation and change the names to *from for consistency
> with list.h

Thank you for taking care of the .clang-format changes!

Acked-by: Miguel Ojeda <miguel.ojeda.sandonis@xxxxxxxxx>