Re: [PATCH v2 3/6] device property: Add a function to obtain a node's prefix

From: Petr Mladek
Date: Wed Mar 27 2019 - 08:37:02 EST


On Tue 2019-03-26 15:32:48, Sakari Ailus wrote:
> Hi Andy,
>
> On Tue, Mar 26, 2019 at 03:16:26PM +0200, Andy Shevchenko wrote:
> > On Tue, Mar 26, 2019 at 02:41:03PM +0200, Sakari Ailus wrote:
> > > The prefix is used for printing purpose before a node, and it also works
> > > as a separator between two nodes.
> > >
> >
> > One nit below.
> >
> > > +static const char *
> > > +acpi_fwnode_get_name_prefix(const struct fwnode_handle *fwnode)
> > > +{
> > > + struct fwnode_handle *parent;
> > > +
> >
> > > + parent = fwnode_get_parent(fwnode);
> > > + /* Root node. */
> >
> > I guess a comment could be easier to read if it goes before parent assignment
> > line.
>
> Only if the comments are changed accordingly. What we're doing here is
> trying to figure out whether this is the root node. I can do that for v3.

IMHO, the comment in acpi_fwnode_get_name() is easier to understand:

/* Is this the root node? */

> >
> > > + if (!parent)
> > > + return "";
> > > +
> > > + parent = fwnode_get_next_parent(parent);
> > > + /* Second node from the root; no prefix here either. */
> >
> > Ditto.

/* Is this 2nd node from the root? */

> > > + if (!parent)
> > > + return "";
> > > +
> > > + fwnode_handle_put(parent);
> > > +
> > > + /* ACPI device or data node. */
> > > + return ".";
> > > +}

Best Regards,
Petr