Re: [PATCH 2/5] lib: rework bitmap_parselist

From: Andy Shevchenko
Date: Wed Apr 03 2019 - 07:22:28 EST


On Wed, Apr 03, 2019 at 07:45:37AM +0300, Yury Norov wrote:
> Remove __bitmap_parselist helper and split the function to logical
> parts.

> /**
> - * __bitmap_parselist - convert list format ASCII string to bitmap
> - * @buf: read nul-terminated user string from this buffer
> - * @buflen: buffer size in bytes. If string is smaller than this
> - * then it must be terminated with a \0.
> - * @is_user: location of buffer, 0 indicates kernel space
> + * bitmap_parselist - convert list format ASCII string to bitmap

> + * @buf: read user string from this buffer; must be terminated
> + * with a \0 or \n.

It's still good idea to put line continuation with deeper level of
indentation.

> * @maskp: write resulting mask here
> * @nmaskbits: number of bits in mask to be written
> *
> @@ -498,127 +619,38 @@ EXPORT_SYMBOL(bitmap_print_to_pagebuf);
> *
> * Returns: 0 on success, -errno on invalid input strings. Error values:
> *
> - * - ``-EINVAL``: second number in range smaller than first
> + * - ``-EINVAL``: wrong region format
> * - ``-EINVAL``: invalid character in string
> * - ``-ERANGE``: bit number specified too large for mask
> + * - ``-EOVERFLOW``: integer overflow in the input parameters
> */

--
With Best Regards,
Andy Shevchenko