Re: [PATCH 01/18] drivers core: Add I/O ASID allocator

From: Andriy Shevchenko
Date: Tue Apr 09 2019 - 11:21:38 EST


On Tue, Apr 09, 2019 at 07:53:08AM -0700, Paul E. McKenney wrote:
> On Tue, Apr 09, 2019 at 01:30:30PM +0300, Andriy Shevchenko wrote:
> > On Tue, Apr 09, 2019 at 03:04:36AM -0700, Christoph Hellwig wrote:
> > > On Tue, Apr 09, 2019 at 01:00:49PM +0300, Andriy Shevchenko wrote:
> > > > I think it makes sense to add a helper macro to rcupdate.h
> > > > (and we have several cases in kernel that can utilize it)
> > > >
> > > > #define kfree_non_null_rcu(ptr, rcu_head) \
> > > > do { \
> > > > if (ptr) \
> > > > kfree_rcu(ptr, rcu_head); \
> > > > } while (0)
> > > >
> > > > as a more common pattern for resource deallocators.
> > >
> > > I think that should move straight into kfree_rcu.
> >
> > Possible. I didn't dare to offer this due to lack of knowledge how it's used in
> > other places.
> >
> > > In general
> > > we expect *free* to deal with NULL pointers transparently, so we
> > > should do so here as well.
> >
> > Exactly my point, thanks.
>
> As shown below?

Looks pretty much good to me, thanks!
Reviewed-by: Andriy Shevchenko <andriy.shevchenko@xxxxxxxxxxxxxxx>

>
> And now that you mention it, it is a bit surprising that no one has
> complained before. ;-)
>
> Thanx, Paul
>
> ------------------------------------------------------------------------
>
> commit 23ad938244968e9d2a8001a1c52887c113b182f6
> Author: Paul E. McKenney <paulmck@xxxxxxxxxxxxx>
> Date: Tue Apr 9 07:48:18 2019 -0700
>
> rcu: Make kfree_rcu() ignore NULL pointers
>
> This commit makes the kfree_rcu() macro's semantics be consistent
> with the likes of kfree() by adding a check for NULL pointers, so
> that kfree_rcu(NULL, ...) is a no-op.
>
> Reported-by: Andriy Shevchenko <andriy.shevchenko@xxxxxxxxxxxxxxx>
> Reported-by: Christoph Hellwig <hch@xxxxxxxxxxxxx>
> Signed-off-by: Paul E. McKenney <paulmck@xxxxxxxxxxxxx>
>
> diff --git a/include/linux/rcupdate.h b/include/linux/rcupdate.h
> index 922bb6848813..c68649b9bcec 100644
> --- a/include/linux/rcupdate.h
> +++ b/include/linux/rcupdate.h
> @@ -828,9 +828,13 @@ static inline notrace void rcu_read_unlock_sched_notrace(void)
> * The BUILD_BUG_ON check must not involve any function calls, hence the
> * checks are done in macros here.
> */
> -#define kfree_rcu(ptr, rcu_head) \
> - __kfree_rcu(&((ptr)->rcu_head), offsetof(typeof(*(ptr)), rcu_head))
> -
> +#define kfree_rcu(ptr, rhf) \
> +do { \
> + typeof (ptr) ___p = (ptr); \
> + \
> + if (___p) \
> + __kfree_rcu(&((___p)->rhf), offsetof(typeof(*(ptr)), rhf)); \
> +} while (0)
>
> /*
> * Place this after a lock-acquisition primitive to guarantee that
>

--
With Best Regards,
Andy Shevchenko