[RFC patch 17/41] tracing: Make stack_trace_print() static and rename it

From: Thomas Gleixner
Date: Wed Apr 10 2019 - 07:05:56 EST


It's only used in the source file where it is defined and it's using the
stack_trace_ namespace. Rename it to free it up for stack trace related
functions.

Signed-off-by: Thomas Gleixner <tglx@xxxxxxxxxxxxx>
Cc: Steven Rostedt <rostedt@xxxxxxxxxxx>
---
include/linux/ftrace.h | 1 -
kernel/trace/trace_stack.c | 4 ++--
2 files changed, 2 insertions(+), 3 deletions(-)

--- a/include/linux/ftrace.h
+++ b/include/linux/ftrace.h
@@ -251,7 +251,6 @@ extern unsigned long stack_trace_max_siz
extern arch_spinlock_t stack_trace_max_lock;

extern int stack_tracer_enabled;
-void stack_trace_print(void);
int
stack_trace_sysctl(struct ctl_table *table, int write,
void __user *buffer, size_t *lenp,
--- a/kernel/trace/trace_stack.c
+++ b/kernel/trace/trace_stack.c
@@ -41,7 +41,7 @@ static DEFINE_MUTEX(stack_sysctl_mutex);
int stack_tracer_enabled;
static int last_stack_tracer_enabled;

-void stack_trace_print(void)
+static void trace_stack_trace_print(void)
{
long i;
int size;
@@ -179,7 +179,7 @@ check_stack(unsigned long ip, unsigned l
stack_trace_max.nr_entries = x;

if (task_stack_end_corrupted(current)) {
- stack_trace_print();
+ trace_stack_trace_print();
BUG();
}