Re: [PATCH RFC 1/5] cpu/speculation: Add 'cpu_spec_mitigations=' cmdline options
From: Thomas Gleixner
Date: Wed Apr 10 2019 - 08:10:35 EST
On Wed, 10 Apr 2019, Michael Ellerman wrote:
> Josh Poimboeuf <jpoimboe@xxxxxxxxxx> writes:
> > On Fri, Apr 05, 2019 at 06:01:36PM +0200, Borislav Petkov wrote:
> >> Thinking about this more, we can shave off the first 4 chars and have it
> >> be:
> >> spec_mitigations=
> >> I think it is painfully clear which speculation mitigations we mean. And
> >> the other switches don't have "cpu_" prefixes too so...
> > Sure, I'm ok with renaming it to that, if there are no objections.
> What about when we have a mitigation for a non-speculation related bug :)
Those kind of silicon bugs are usually mitigated unconditionally.