Re: [PATCH RFC 1/5] cpu/speculation: Add 'cpu_spec_mitigations=' cmdline options
From: Michael Ellerman
Date: Thu Apr 11 2019 - 22:41:27 EST
Josh Poimboeuf <jpoimboe@xxxxxxxxxx> writes:
> On Wed, Apr 10, 2019 at 02:10:01PM +0200, Thomas Gleixner wrote:
>> On Wed, 10 Apr 2019, Michael Ellerman wrote:
>> > Josh Poimboeuf <jpoimboe@xxxxxxxxxx> writes:
>> > > On Fri, Apr 05, 2019 at 06:01:36PM +0200, Borislav Petkov wrote:
>> > >> Thinking about this more, we can shave off the first 4 chars and have it
>> > >> be:
>> > >>
>> > >> spec_mitigations=
>> > >>
>> > >> I think it is painfully clear which speculation mitigations we mean. And
>> > >> the other switches don't have "cpu_" prefixes too so...
>> > >
>> > > Sure, I'm ok with renaming it to that, if there are no objections.
>> > What about when we have a mitigation for a non-speculation related bug :)
>> Those kind of silicon bugs are usually mitigated unconditionally.
> But at least "mitigations=" is nice and short. We could clarify in the
> documentation that it doesn't apply to *all* mitigations, only the ones
> which are optional and which can affect performance.
> And it would give us the freedom to include any future "optional"
> mitigations, spec or not.
> I kind of like it. But I could go either way.
Some of the published SMT attacks are not speculation based.
And arguably we already have an optional mitigation for those, ie. nosmt.