[RFC PATCH 0/2] Introduce size_to_sectors helper in blkdev.h
From: Marcos Paulo de Souza
Date: Sat Apr 20 2019 - 23:53:43 EST
While reading code of drivers/block, I was curious about the set_capacity
argument, always shifting the value by 9, and so I took me a while to realize
this is done on purpose: the capacity is the number of sectors of 512 bytes
related to the storage space.
Rather the shifting by 9, there are other places where the value if shifted by
SECTOR_SHIFT, which is more readable.
This patch aims to reduce these differences by adding a new function called
size_to_sectors, adding a proper comment explaining why this is needed.
null_blk was changed to use this new function.
This is an RFC, please let me know if you have other suggestions.
Marcos Paulo de Souza (2):
blkdev.h: Introduce size_to_sectors hlper function
null_blk: Make use of size_to_sectors helper
drivers/block/null_blk_main.c | 18 +++++++++---------
include/linux/blkdev.h | 18 ++++++++++++++++++
2 files changed, 27 insertions(+), 9 deletions(-)