Re: [RFC 1/6] objtool: Refactor code to make it more suitable for multiple architecture support
From: Josh Poimboeuf
Date: Wed Apr 24 2019 - 12:17:36 EST
On Wed, Apr 24, 2019 at 04:11:57PM +0000, Raphael Gault wrote:
> On 4/23/19 9:13 PM, Josh Poimboeuf wrote:
> > arch_dest_rela_addend_offset() might be a more descriptive name. Also
> > it might be simpler to just make it an arch-specific macro which is 0 on
> > arm64 and 4 on x86.
> > "compute" is implied, it can probably be removed from the names to make
> > them a little more concise.
> I am more in favor of the functions, I have to admit I don't know which
> is really better but in any event I will rename them.
If you prefer functions, that's fine with me. I don't have a strong