On Fri, May 10, 2019 at 10:12:40AM +0800, Huang, Ying wrote:
Please don't. That embeds the knowledge that we can only swap out either+ nr_reclaimed += (1 << compound_order(page));How about to change this to
nr_reclaimed += hpage_nr_pages(page);
normal pages or THP sized pages. I'm trying to make the VM capable of
supporting arbitrary-order pages, and this would be just one more place
I'm sympathetic to the "self documenting" argument. My current tree has
a patch in it:
mm: Introduce compound_nr
Replace 1 << compound_order(page) with compound_nr(page). Minor
improvements in readability.
It goes along with this patch:
mm: Introduce page_size()
It's unnecessarily hard to find out the size of a potentially huge page.
Replace 'PAGE_SIZE << compound_order(page)' with page_size(page).
Better suggestions on naming gratefully received. I'm more happy with
page_size() than I am with compound_nr(). page_nr() gives the wrong
impression; page_count() isn't great either.