Re: [PATCH] mm: vmscan: correct nr_reclaimed for THP
From: William Kucharski
Date: Sat May 11 2019 - 18:41:35 EST
> On May 10, 2019, at 10:36 AM, Matthew Wilcox <willy@xxxxxxxxxxxxx> wrote:
> Please don't. That embeds the knowledge that we can only swap out either
> normal pages or THP sized pages. I'm trying to make the VM capable of
> supporting arbitrary-order pages, and this would be just one more place
> to fix.
> I'm sympathetic to the "self documenting" argument. My current tree has
> a patch in it:
> mm: Introduce compound_nr
> Replace 1 << compound_order(page) with compound_nr(page). Minor
> improvements in readability.
> It goes along with this patch:
> mm: Introduce page_size()
> It's unnecessarily hard to find out the size of a potentially huge page.
> Replace 'PAGE_SIZE << compound_order(page)' with page_size(page).
> Better suggestions on naming gratefully received. I'm more happy with
> page_size() than I am with compound_nr(). page_nr() gives the wrong
> impression; page_count() isn't great either.
I like page_size() as well. At least to me, page_nr() or page_count() would
imply a basis of PAGESIZE, or that you would need to do something like:
page_size = page_nr() << PAGE_SHIFT;
to get the size in bytes; page_size() is more straightforward in that respect.