Re: [PATCH] ACPI / LPSS: Don't skip late system PM ops for hibernate on BYT/CHT

From: Hans de Goede
Date: Tue May 14 2019 - 06:12:45 EST


On 5/9/19 8:09 PM, Robert R. Howell wrote:
Hi Hans

On 5/9/19 2:50 AM, Hans de Goede wrote:


On 09-05-19 06:24, Robert R. Howell wrote:
On 4/30/19 8:39 AM, Hans de Goede wrote:

I've just tried to reproduce the "Error i2c_dw_xfer call while suspended" error
on suspend/resume on my own T100TA and I could not reproduce this.

Can you try without the BT keyboard paired and waking up from suspend using the
tablet part's power-button ?

Also do you still have the scripts to rmmod some modules before suspend ?

The T100TA keyboard is actually a hardwired connection rather than Bluetooth but I
did physically disconnect the keyboard, and also unpaired all the actual Bluetooth
devices (such as the mouse) and then powered down the T100TA bluetooth adapter.
When I suspend, then resume using the tablet power button, I still get the
i2c_dw_xfererror error during the resume. But whatever causes this error isn't fatal,
in the sense that after resume the sound and other i2c functions do still work OK.

While I always get this i2c_dw_xfer error on resume from suspend or hibernation on the T100TA,
I also have a T100TAM and curiously, it NEVER shows that error -- although all the
other suspend and hibernate behavior seems similar. I'm not sure if the following could
be the difference, but the T100TA uses an i2c connected ATML1000 touchscreen controller
while the T100TAM uses an i2c connected SIS0817 touchscreen controller. Other than that
the hardware seems almost identical.

I've been testing on an actual T100TA, with the ATML1000 touchscreen controller.

Maybe it is a difference in BIOS version, my T100TA is running the latest BIOS, what
is the output of:

cat /sys/class/dmi/id/bios_version /sys/class/dmi/id/bios_date

On the T100TA which shows the i2c_dw_xfer error the above cat reports:

My T100TA has version T100TA.314, date 08/13/2015

while the T100TA which does NOT show the i2c_dw_xfer error reports:

Also do you perhaps have a microsd card inserted? (I'm trying to figure out the
different between our setups so that I can hopefully reproduce the issue myself).

I do have a microsd card inserted in both the T100TA and the T100TAM.

Ok, so I tried reproducing the suspend/resume problem on my T100TA with a microsd
inserted and mounted and I still cannot reproduce the problem. So either you are
hitting a BIOS bug which since has been fixed, or the suspend/resume
problem is caused by you removing the DPM_FLAG_SMART_SUSPEND flag.