Re: [PATCH 2/3] regulator: qcom_spmi: Add support for PM8005

From: Mark Brown
Date: Tue May 21 2019 - 14:53:40 EST


On Tue, May 21, 2019 at 09:53:15AM -0700, Jeffrey Hugo wrote:

> - spmi_vreg_read(vreg, SPMI_COMMON_REG_VOLTAGE_RANGE, &range_sel, 1);
> + /* second common devices don't have VOLTAGE_RANGE register */
> + if (vreg->logical_type == SPMI_REGULATOR_LOGICAL_TYPE_FTSMPS2) {
> + spmi_vreg_read(vreg, SPMI_COMMON2_REG_VOLTAGE_LSB, &lsb, 1);
> + spmi_vreg_read(vreg, SPMI_COMMON2_REG_VOLTAGE_MSB, &msb, 1);
> +
> + uV = (((int)msb << 8) | (int)lsb) * 1000;

This overlaps with some changes that Jorge (CCed) was sending for the
PMS405. As I was saying to him rather than shoving special cases for
different regulator types into the ops (especially ones that don't have
any of the range stuff) it'd be better to just define separate ops for
the regulators that look quite different to the existing ones.

> +static int spmi_regulator_common_list_voltage(struct regulator_dev *rdev,
> + unsigned selector);
> +
> +static int spmi_regulator_common2_set_voltage(struct regulator_dev *rdev,
> + unsigned selector)

Eeew, can we not have better names?

> +static unsigned int spmi_regulator_common2_get_mode(struct regulator_dev *rdev)
> +{
> + struct spmi_regulator *vreg = rdev_get_drvdata(rdev);
> + u8 reg;
> +
> + spmi_vreg_read(vreg, SPMI_COMMON2_REG_MODE, &reg, 1);
> +
> + if (reg == SPMI_COMMON2_MODE_HPM_MASK)
> + return REGULATOR_MODE_NORMAL;
> +
> + if (reg == SPMI_COMMON2_MODE_AUTO_MASK)
> + return REGULATOR_MODE_FAST;
> +
> + return REGULATOR_MODE_IDLE;
> +}

This looks like you want to write a switch statement.

> +spmi_regulator_common2_set_mode(struct regulator_dev *rdev, unsigned int mode)
> +{
> + struct spmi_regulator *vreg = rdev_get_drvdata(rdev);
> + u8 mask = SPMI_COMMON2_MODE_MASK;
> + u8 val = SPMI_COMMON2_MODE_LPM_MASK;
> +
> + if (mode == REGULATOR_MODE_NORMAL)
> + val = SPMI_COMMON2_MODE_HPM_MASK;
> + else if (mode == REGULATOR_MODE_FAST)
> + val = SPMI_COMMON2_MODE_AUTO_MASK;

This needs to be a switch statement, then it can have a default case to
catch errors too.

Attachment: signature.asc
Description: PGP signature