Re: [PATCH][next] IB/rdmavt: Use struct_size() helper

From: Jason Gunthorpe
Date: Thu May 30 2019 - 14:46:43 EST


On Wed, May 29, 2019 at 10:12:48AM -0500, Gustavo A. R. Silva wrote:
> Make use of the struct_size() helper instead of an open-coded version
> in order to avoid any potential type mistakes, in particular in the
> context in which this code is being used.
>
> So, replace the following form:
>
> sizeof(struct rvt_sge) * init_attr->cap.max_send_sge + sizeof(struct rvt_swqe)
>
> with:
>
> struct_size(swq, sg_list, init_attr->cap.max_send_sge)
>
> and so on...
>
> Also, notice that variable size is unnecessary, hence it is removed.
>
> This code was detected with the help of Coccinelle.
>
> Signed-off-by: Gustavo A. R. Silva <gustavo@xxxxxxxxxxxxxx>
> Reviewed-by: Dennis Dalessandro <dennis.dalessandro@xxxxxxxxx>
> ---
> drivers/infiniband/sw/rdmavt/qp.c | 4 +---
> 1 file changed, 1 insertion(+), 3 deletions(-)

Applied to for-next, thanks

Jason