Re: [PATCH 1/2] bpf, riscv: fix bugs in JIT for 32-bit ALU operations

From: Luke Nelson
Date: Thu May 30 2019 - 18:38:03 EST


On Thu, May 30, 2019 at 1:53 PM Song Liu <liu.song.a23@xxxxxxxxx> wrote:
>
> This is a little messy. How about we introduce some helper function
> like:
>
> /* please find a better name... */
> emit_32_or_64(bool is64, const u32 insn_32, const u32 inst_64, struct
> rv_jit_context *ctx)
> {
> if (is64)
> emit(insn_64, ctx);
> else {
> emit(insn_32, ctx);
> rd = xxxx;
> emit_zext_32(rd, ctx);
> }
> }

This same check is used throughout the file, maybe clean it up in a
separate patch?