Re: [RFC V2] mm: Generalize notify_page_fault()
From: Matthew Wilcox
Date: Wed Jun 05 2019 - 07:27:36 EST
On Wed, Jun 05, 2019 at 09:19:22PM +1000, Michael Ellerman wrote:
> Anshuman Khandual <anshuman.khandual@xxxxxxx> writes:
> > Similar notify_page_fault() definitions are being used by architectures
> > duplicating much of the same code. This attempts to unify them into a
> > single implementation, generalize it and then move it to a common place.
> > kprobes_built_in() can detect CONFIG_KPROBES, hence notify_page_fault()
> > need not be wrapped again within CONFIG_KPROBES. Trap number argument can
> > now contain upto an 'unsigned int' accommodating all possible platforms.
> You've changed several of the architectures from something like above,
> where it disables preemption around the call into the below:
> Which skips everything if we're preemptible. Is that an equivalent
> change? If so can you please explain why in more detail.
See the discussion in v1 of this patch, which you were cc'd on.
I agree the description here completely fails to mention why the change.
It should mention commit a980c0ef9f6d8c.
> Also why not have it return bool?