Re: [RFC V3] mm: Generalize and rename notify_page_fault() as kprobe_page_fault()

From: Stephen Rothwell
Date: Fri Jun 07 2019 - 08:08:35 EST


Hi Anshuman,

On Fri, 7 Jun 2019 16:04:15 +0530 Anshuman Khandual <anshuman.khandual@xxxxxxx> wrote:
>
> +static nokprobe_inline bool kprobe_page_fault(struct pt_regs *regs,
> + unsigned int trap)
> +{
> + int ret = 0;
> +
> + /*
> + * To be potentially processing a kprobe fault and to be allowed
> + * to call kprobe_running(), we have to be non-preemptible.
> + */
> + if (kprobes_built_in() && !preemptible() && !user_mode(regs)) {
> + if (kprobe_running() && kprobe_fault_handler(regs, trap))
> + ret = 1;
> + }
> + return ret;
> +}

Since this is now declared as "bool" (thanks for that), you should make
"ret" be bool and use true and false;

--
Cheers,
Stephen Rothwell

Attachment: pgpE9hcG5EpFq.pgp
Description: OpenPGP digital signature