Re: [RFC V3] mm: Generalize and rename notify_page_fault() as kprobe_page_fault()
From: Anshuman Khandual
Date: Mon Jun 10 2019 - 01:10:55 EST
On 06/10/2019 10:27 AM, Dave Hansen wrote:
> On 6/9/19 9:34 PM, Anshuman Khandual wrote:
>>> Do you really think this is easier to read?
>>> Why not just move the x86 version to include/linux/kprobes.h, and replace
>>> the int with bool?
>> Will just return bool directly without an additional variable here as suggested
>> before. But for the conditional statement, I guess the proposed one here is more
>> compact than the x86 one.
> FWIW, I don't think "compact" is generally a good goal for code. Being
> readable is 100x more important than being compact and being un-compact
> is only a problem when it hurts readability.
> For a function like the one in question, having the individual return
> conditions clearly commented is way more important than saving 10 lines
> of code.
Fair enough. Will keep the existing code flow from x86.