Re: [PATCH] i2c: mux: Use struct_size() in devm_kzalloc()

From: Peter Rosin
Date: Tue Jun 11 2019 - 03:16:37 EST


On 2019-05-29 18:20, Gustavo A. R. Silva wrote:
> One of the more common cases of allocation size calculations is finding
> the size of a structure that has a zero-sized array at the end, along
> with memory for some number of elements for that array. For example:
>
> struct foo {
> int stuff;
> struct boo entry[];
> };
>
> instance = devm_kzalloc(dev, sizeof(struct foo) + count * sizeof(struct boo), GFP_KERNEL);
>
> Instead of leaving these open-coded and prone to type mistakes, we can
> now use the new struct_size() helper:
>
> instance = devm_kzalloc(dev, struct_size(instance, entry, count), GFP_KERNEL);
>
> This code was detected with the help of Coccinelle.

Thanks, patch applied to i2c-mux/for-next

Cheers,
Peter