Re: Coccinelle: api: add devm_platform_ioremap_resource script

From: Markus Elfring
Date: Wed Jun 12 2019 - 02:29:19 EST

>> The flag âIORESOURCE_MEMâ is passed as the second parameter for the call
>> of the function âplatform_get_resourceâ in this refactoring.
> In that particular case, we maybe should consider separate inline
> helpers instead of passing this is a parameter.
> Maybe it would even be more efficient to have completely separate
> versions of devm_platform_ioremap_resource(), so we don't even have
> to pass that parameter on stack.

Would you like to add another function which should be called instead of
the combination of the functions âplatform_get_resourceâ and âdevm_ioremap_resourceâ?