Re: [PATCH v1 0/6] mm / virtio: Provide support for paravirtual waste page treatment

From: Dave Hansen
Date: Tue Jun 25 2019 - 10:10:57 EST

On 6/25/19 12:42 AM, David Hildenbrand wrote:
> On 20.06.19 00:32, Alexander Duyck wrote:
> I still *detest* the terminology, sorry. Can't you come up with a
> simpler terminology that makes more sense in the context of operating
> systems and pages we want to hint to the hypervisor? (that is the only
> use case you are using it for so far)

It's a wee bit too cute for my taste as well. I could probably live
with it in the data structures, but having it show up out in places like
Kconfig and filenames goes too far.

For instance, someone seeing memory_aeration.c will have no concept
what's in the file. Could we call it something like memory_paravirt.c?
Or even mm/paravirt.c.

Could you talk for a minute about why the straightforward naming like
"hinted/unhinted" wasn't used? Is there something else we could ever
use this infrastructure for that is not related to paravirtualized free
page hinting?