Re: [PATCH v7 02/10] mm: rename slab delayed deactivation functions and fields
From: Shakeel Butt
Date: Tue Jun 25 2019 - 14:17:21 EST
On Tue, Jun 11, 2019 at 4:18 PM Roman Gushchin <guro@xxxxxx> wrote:
> The delayed work/rcu deactivation infrastructure of non-root
> kmem_caches can be also used for asynchronous release of these
> objects. Let's get rid of the word "deactivation" in corresponding
> names to make the code look better after generalization.
> It's easier to make the renaming first, so that the generalized
> code will look consistent from scratch.
> Let's rename struct memcg_cache_params fields:
> deact_fn -> work_fn
> deact_rcu_head -> rcu_head
> deact_work -> work
> And RCU/delayed work callbacks in slab common code:
> kmemcg_deactivate_rcufn -> kmemcg_rcufn
> kmemcg_deactivate_workfn -> kmemcg_workfn
> This patch contains no functional changes, only renamings.
> Signed-off-by: Roman Gushchin <guro@xxxxxx>
> Acked-by: Vladimir Davydov <vdavydov.dev@xxxxxxxxx>
Reviewed-by: Shakeel Butt <shakeelb@xxxxxxxxxx>