Re: [PATCH 14/16] mm: move the powerpc hugepd code to mm/gup.c
From: Andrew Morton
Date: Tue Jun 25 2019 - 15:38:00 EST
On Tue, 25 Jun 2019 16:37:13 +0200 Christoph Hellwig <hch@xxxxxx> wrote:
> +static int gup_huge_pd(hugepd_t hugepd
Naming nitlet: we have hugepd and we also have huge_pd. We have
hugepte and we also have huge_pte. It make things a bit hard to
remember and it would be nice to make it all consistent sometime.
We're consistent with huge_pud and almost consistent with huge_pmd.
To be fully consistent I guess we should make all of them have the
underscore. Or not have it.